Quantcast
Channel: SQL Server Cluster Archives - SQL Authority with Pinal Dave
Browsing index pages (53 articles)

Image may be NSFW.
Clik here to view.

SQL SERVER – LogonUserExEx Fails for User & GetToken – Logging on as the CNO...

SQL Always-On feature is so tied to cluster that sometimes you would need to look at various logs to fix a failure. In this blog I would share my learning about fixing error LogonUserExEx fails for...

View Article


Image may be NSFW.
Clik here to view.

SQL SERVER – Always On Listener Not Coming Online – Failed to Create New NBT...

During the recent consulting engagement Comprehensive Database Performance Health Check with my client, one of the DBA was busy with Always On deployment. He asked me if I can help him with some...

View Article


Image may be NSFW.
Clik here to view.

SQL SERVER – Always On Listener Creation Failure – Enabling Object...

In the past, I have written a few blogs where I explained a few issues about the failure of listener creation Failure in a cluster. In this blog, we would see another cause of listener creation...

View Article

Image may be NSFW.
Clik here to view.

SQL SERVER – Always On Listener Failure – Provisioning Computer Object Failed...

In the past, I have written a few blogs where I explained a few issues about the failure of listener creation in the cluster. In this blog, we would see another cause of listener creation failure. I...

View Article

Image may be NSFW.
Clik here to view.

SQL SERVER – Drop failed for Availability Group – Failed to Destroy the...

While working with one of the clients to recover from a disaster, I encountered an error. In this blog we would talk about error Drop failed for Availability Group. If you want any such assistance, you...

View Article


Image may be NSFW.
Clik here to view.

SQL SERVER – LogonUserExEx Fails for User & GetToken – Logging on as the CNO...

SQL Always-On feature is so tied to cluster that sometimes you would need to look at various logs to fix a failure. In this blog I would share my learning about fixing error LogonUserExEx fails for...

View Article

Image may be NSFW.
Clik here to view.

SQL SERVER – Always On Listener Not Coming Online – Failed to Create New NBT...

During the recent consulting engagement Comprehensive Database Performance Health Check with my client, one of the DBA was busy with Always On deployment. He asked me if I can help him with some...

View Article

Image may be NSFW.
Clik here to view.

SQL SERVER – Always On Listener Creation Failure – Enabling Object...

In the past, I have written a few blogs where I explained a few issues about the failure of listener creation Failure in a cluster. In this blog, we would see another cause of listener creation...

View Article


Image may be NSFW.
Clik here to view.

SQL SERVER – Always On Listener Failure – Provisioning Computer Object Failed...

In the past, I have written a few blogs where I explained a few issues about the failure of listener creation in the cluster. In this blog, we would see another cause of listener creation failure.I...

View Article


Image may be NSFW.
Clik here to view.

SQL SERVER – Drop failed for Availability Group – Failed to Destroy the...

While working with one of the clients to recover from a disaster, I encountered an error. In this blog we would talk about error Drop failed for Availability Group. If you want any such assistance, you...

View Article

Image may be NSFW.
Clik here to view.

SQL SERVER – FIX: The specified instance of SQL Server is hosted by a system...

Sometimes if the sequence is not followed correctly, we might see some weird errors. In this blog, we would learn how to fix always on an error while adding new replica “The specified instance of SQL...

View Article

Image may be NSFW.
Clik here to view.

SQL SERVER – Availability Group Seen in SSMS but missing in Cluster Manager....

One of my existing clients has sent me an interesting question. In this blog, I would share one interesting situation where my client has created an availability group and it was visible in SSMS, but...

View Article

Image may be NSFW.
Clik here to view.

SQL SERVER – Patch Failure – Unable to Retrieve the Cluster Service

Few of my clients are still running older versions of SQL Server and they have their own reasons to not to move to the new SQL version. In this blog, we would learn about the fix of an error for which...

View Article


Image may be NSFW.
Clik here to view.

SQL SERVER – SQL Clustered Resource in Online Pending State for Long Time...

While doing Comprehensive Database Performance Health Check I always ask my client if there is any pain point which they have with the current state of the database/server. Once I got an interesting...

View Article

Image may be NSFW.
Clik here to view.

SQL SERVER – Always On Availability Group Listener Missing in SSMS but...

I have helped many customers to solve complex issues in their environment by Comprehensive Database Performance Health Check. Sometimes, the issue looks very complex but once the solution is found it...

View Article


Image may be NSFW.
Clik here to view.

SQL SERVER – Error: Parameter ‘ProbePort’ does not exist on the cluster...

Azure is gaining popularity and I am getting clients who want to create Always On availability group as their high availability solution in Azure Virtual machine. To keep myself up to date, I also try...

View Article

Image may be NSFW.
Clik here to view.

SQL SERVER – Steps to Change IP Address of SQL Server Failover Cluster Instance

There have been many questions in my mailbox asking about exact steps to change the windows cluster and SQL failover cluster IP address to the new VLAN. In this blog, I would outline the steps which...

View Article


Image may be NSFW.
Clik here to view.

SQL SERVER – Always On AG – HADRAG: Did not Find the Instance to Connect in...

During my On Demand (50 Minutes) consultancy, I solve the issue which seems quick to my client. SQL not starting, AlwaysOn not failing over, Cluster not working are few of quick things where my clients...

View Article

Image may be NSFW.
Clik here to view.

SQL SERVER – Event ID: 1135 – Cluster node ‘NodeName’ was Removed From the...

When I work with customers, there are situations when I get chance to learn something from them. I was engaged with an AlwaysOn availability group engagement and got some interesting information from a...

View Article

Image may be NSFW.
Clik here to view.

SQL SERVER – Unable to Start SQL Resource in Cluster – HUGE Master Database!

One of my clients contacted me and informed that SQL in cluster failed over from Node 01 to Node 02. It failed to come online on Node 02, failed back to Node 01, and it failed to come online there...

View Article
Browsing index pages (53 articles)


Latest Images